Microsoft 365 Service Degradation

Incident Report for Zapmail

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 11:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 24, 2026 - 04:27 UTC

Investigating

Some users may currently experience degraded functionality or be unable to access one or more Microsoft 365 services. This issue originates from Microsoft's infrastructure and may impact authentication and service availability.
Mailbox creation is currently affected due to this incident. Existing Microsoft mailboxes are not impacted and will continue to function normally.
Microsoft is actively investigating the issue and working toward a resolution. We are monitoring the situation closely and will provide updates as more information becomes available.
Posted Jan 23, 2026 - 08:41 UTC
This incident affected: Integration with Microsoft.