Degraded Performance – Google Mailbox Creation Pipelines

Incident Report for Zapmail

Resolved

This incident has been resolved.
Posted May 16, 2026 - 14:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2026 - 06:45 UTC

Investigating

We are currently experiencing degraded performance affecting new google mailbox creation in Zapmail.
- Delays in creating and activating new mailboxes
- Setup times may exceed the usual 40 minutes window

What’s NOT Impacted
- All existing mailboxes are fully operational
- Sending, receiving, exports, and integrations continue to work normally
- DNS, forwarding, and automation remain unaffected

Our team is actively investigating and working to restore normal creation times as quickly as possible.

We’ll provide updates here as progress is made.
Posted May 14, 2026 - 13:38 UTC
This incident affected: Integration with Google.